StageNow Troubleshooting

StageNow 5.14

This section covers common errors that can occur when using StageNow and offers advice on how to address them.


XML Configuration Failure

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Problem

The message "FMC download FTP File Read timed out" (or similar) appears in the device when staging completes.

Cause

This error generally occurs when FTP is used during staging to download a large file (greater than 1.5 GB) from a public server.

Solution

Try using FTPS instead of FTP for the file transfer.


Wi-Fi Hotspot

NOTE: Wi-Fi Hotspot staging is NOT supported on systems running Windows 10.

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Problem

The message "Unable to turn on the Wi-Fi Hotspot" (or similar) appears when attempting to turn on the StageNow Wi-Fi Hotspot feature.

Cause

This can occur if the Wi-Fi adapter in the host PC is not initialized or is inactive when StageNow launches.

Solution

Try the following steps to resolve the issue:

Restart Wi-Fi Adapter
  1. Right-click on the Network icon on the bottom right corner of the Windows host and select Open Network and Sharing Center to open the following screen.

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  2. On the left pane, select Change adapter settings.

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  3. Open a command prompt and enter "netsh wlan show drivers" to find the Wi-Fi driver adapter name.

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  4. Right-click on the network adapter in the Network Connections window and select Disable.

  5. Right-click again and select Enable. After a few minutes, try using the StageNow Tool.

Add Unsupported Hotspot

Note: Results that deviate from the following can be considered a Windows driver/software issue regarding the Wi-Fi hotspot.

  1. Open a command prompt as an Administrator.

  2. Enter "netsh wlan show drivers" and locate the result message outlined in green below.

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    The following message appears if the system does not support the Wi-Fi hotspot.

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  3. Enter the following command in the command prompt: "netsh wlan set hostednetwork mode=allow ssid= key= ""

    Note: HotspotName is the name of Wi-Fi hotspot.

    HotspotPassword is the Wi-Fi hotspot password and must be at least 5 characters.

    The following result appears after successful creation of the Wi-Fi hotspot.

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  4. Enter "netsh wlan start hostednetwork" to start the hotspot.

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  5. Enter "netsh wlan stop hostednetwork" to stop the hotspot.

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Downloaded file Corrupted

Problem

The message "Downloaded file is corrupted, this may be due to instable network connection" (or similar) appears when attempting to perform the "Transfer/Copy File" Action to transfer a file from the admin host PC to a device.

Cause

This is due to checksum mismatch between source and destination files.

Solution

Try the following steps to resolve the issue:

  • If the Profile was created on PC other than the one on which the error occurred and imported into StageNow:
    • a. Navigate to the FileMgr section of the imported Profile
    • b. Edit the Source Path and File parameter so the path to the file to be copied matches that of the PC currently in use
    • c. Save changes and generate a new barcode
  • If the Profile was created on the admin host PC currently in use:
    • a. Navigate to the %appdata%\StageNow\AST\FTP\PROFILES folder on the admin host PC
    • b. Delete the checksum file found there
    • c. Save changes and generate a new barcode

Plug-in CSP Issues

Profiles created with plug-in CSPs behave differently than those made with built-in CSPs. The most important difference involves Profile importation and deletion.

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Problem

An error occurs when attempting to delete an .apk imported into the CSP library as a plug-in CSP.

Solution

  1. Export all profiles to a location on the administrator host PC.
  2. Delete the StageNow DB from the %appdata% directory on the PC.
  3. Re-import the exported profiles.